Our marketing website (www.abstract.com) is down
Incident Report for Abstract
Resolved
This incident has been resolved.
Posted Oct 14, 2019 - 09:43 PDT
Investigating
We're investigating an issue with our marketing website (www.abstract.com). To access your projects, visit app.goabstract.com.
Posted Oct 14, 2019 - 09:38 PDT
This incident affected: Abstract Website.