Issues with committing, merging, and syncing in Abstract for Sketch
Incident Report for Abstract
Resolved
We have completed monitoring and believe that the root cause of the issue has been resolved.

Support will continue to work with those who may be experiencing secondary issues caused by this issue such as diverged branches. If you continue to experience sync troubles, please write us through the in-app support form or via support@abstract.com and attach a fresh set of debug logs. We’ll be happy to assist.
Posted Oct 12, 2021 - 14:44 PDT
Monitoring
As of late Friday afternoon, October 8th, we believe we have released a fix for the root cause of the issues customers were experiencing while syncing, merging, and committing. We're monitoring the situation and continuing to keep an eye out for additional reports or a spike in related errors.

If you experienced sync issues during this incident, but you did not attempt to merge a branch, the current workaround is to Force Push the branch from the Development menu.

If you attempted to merge a branch during this incident and your branch is now merged or archived, but not synced to the web app as expected, the current workaround is to:

1. Open the Abstract desktop app.
2. Select the project with the branch you’d like to archive / delete.
3. Select Branches from the left side pane.
4. Select the Archived tab to view the archived branches in the project.
5. Use the search bar, author filter, or scroll to locate the branch that may have been archived
6. Click the ... menu at the far right side of the branch name.
7. Either select "New Child Branch..." or "Export files"

a. If you selected "New Child Branch...":
1. Name your branch
2. Merge your branch into Master, or continue work on that branch

b. If you selected "Export files":
1. Choose a location to export all of the project files from that branch
2. Create a new Branch
3. Re-Add your files to the project on your newly created Branch
Posted Oct 11, 2021 - 10:49 PDT
Identified
We're investigating reports from some Abstract for Sketch users of problems with committing, merging, and syncing. We believe we've identified the issue and are working to deploy the fix.
Posted Oct 08, 2021 - 07:22 PDT
This incident affected: Sketch Plugin.