Web app inaccessible
Incident Report for Abstract
Resolved
This incident has been resolved.
Posted 8 months ago. Nov 27, 2018 - 13:10 PST
Update
We are continuing to investigate this issue.
Posted 8 months ago. Nov 27, 2018 - 12:53 PST
Investigating
We are currently investigating this issue.
Posted 8 months ago. Nov 27, 2018 - 12:52 PST
This incident affected: app.goabstract.com.